作者尝试使用Nuget添加Mongodb相关依赖包。笔者尝试利用Nuget添加Mongodb相关依赖包。

状况描述

参考

读者可选更轻量的主意,仅升级Nuget。

前不久,再次利用Nuget添加sqlite包,发现尚是有兼容性问题。于是笔者对有利于小组的琢磨,尝试解决是题材。

笔者之VS2012版本比较老旧,是几乎年以前下载的。平时加上三正担保及教包都是手动添加。后来打探及发Nuget这个家伙,如获得至宝。可是在使用过程遭到倒产生了很多题材。

 

点击工具栏  工具->扩展及换代->更新,更新VS。

 

经过长期的等,终于升迁就,再次安装依赖包,成功。

早期,笔者尝试利用Nuget添加Mongodb相关依赖包,结果提示靠包以及Nuget版本不兼容。因为既出了手动下充斥好之保险,所以便从未当一点一滴,手动添加了依赖包。

题材讲述

VS2012于的提议是提升Nuget,但是笔者考虑到温馨的VS版本太老,指不定哪天再冒充出什么问题,索性叫VS来平等不善升级。

“System.Data.SQLite.EF6”的架构版本和 NuGet 的版 2.0.30625.9003
不般配,请尝试到Nuget官网升级最新版Nuget。

釜底抽薪方案

釜底抽薪方案

 

 

观描述

参考

https://stackoverflow.com/questions/21766168/visual-studio-2012-package-manager-console-error

不久前,再次以Nuget添加sqlite包,发现还是存在兼容性问题。于是笔者对有利于小组的思量,尝试解决之问题。

笔者之VS2012本子比较老旧,是几乎年以前下载的。平时丰富三方担保以及让包都是手动添加。后来了解及起Nuget这个家伙,如获得至宝。可是以动过程中却发了成百上千题目。

 

“System.Data.SQLite.EF6”的架构版本与 NuGet 的本 2.0.30625.9003
不兼容,请尝试到Nuget官网升级时版Nuget。

头,笔者尝试下Nuget添加Mongodb相关依赖包,结果提示靠包和Nuget版本不般配。因为已经闹矣手动下充斥好的保证,所以即便无当全,手动添加了依赖包。

点击工具栏  工具->扩展和翻新->更新,更新VS。

 

背景

采取VS2012从带Nuget安装System.Data.Sqlite依赖包,解析、下载和安装前半有的都无问题,在装最后之System.Data.SQLite.EF6时出现兼容性问题。

 

VS2012于的提议是升级Nuget,但是笔者考虑到祥和之VS版本太老,指不定哪天再冒充出什么问题,索性让VS来平等次于升级。

题目讲述

https://stackoverflow.com/questions/21766168/visual-studio-2012-package-manager-console-error

下VS2012从带Nuget安装System.Data.Sqlite依赖包,解析、下载和安装前半片段都无问题,在装置最后之System.Data.SQLite.EF6时出现兼容性问题。

 

读者可以选更加轻量的方式,仅升级Nuget。

背景

通过长期的守候,终于升迁就,再次安装依赖包,成功。

相关文章